[Plugin] samp-compat: Intercompatibilidad entre versiones

¿Encontraste un Plugin que te asombró? ¿Qué opinas de mostrárnoslo? ¡Súbelo y compártelo con los demás! También, encuentra gran cantidad de Includes.

Moderador: Ayudantes

Reglas del Foro
  • Si publicas un Plugin de tu autoría, deberás publicar el código fuente del mismo. No olvides utilizar el BBCode [Pawn]Código aquí[/Pawn].
  • Si no eres el autor del plugin/include o has utilizado códigos de otros autores, recuerda colocar los créditos correspondientes. (El plagio es motivo de sanción).
Responder
Avatar de Usuario
Graber
Ayudante
Ayudante
Mensajes: 194
Registrado: 10 Abr 2016 19:16
Contactar:
Reputación: 22

03 Mar 2019 19:05

samp-compat

Imagen

Permite conexiones de clientes SA-MP antes no compatibles hacia servidores con versiones mas nuevas/viejas, permitiendo tener a jugadores de versiones diferentes jugando sin software adicional.

Versiones soportadas
  • 0.3.7-R2 (ambas R2-1 y R2-2): Soporta clientes de la 0.3.DL
  • 0.3.DL: Soporta clientes de la 0.3.7 (R1, R2 y R3)

Instalación

Usuarios de sampctl pueden usar:

Código: Seleccionar todo

sampctl package install AGraber/samp-compat
O, descargar manualmente el .zip y colocar el plugin en la carpeta plugins:
https://github.com/AGraber/samp-compat/releases

Opcionalmente, lo puedes incluir en tu código para detectar players que esten conectados bajo la capa de compatibilidad.

Código: Seleccionar todo

#include <compat>
Y eso es todo! Asi de sencillo, a diferencia del include anterior. Asegurate de usar solo dynamic objects si tu server es 0.3.DL, o pueden experimentar crashes los jugadores de la 0.3.7.


Agradecimientos
  • Estructuras de memoria del server SA-MP proveidas por contribuidores del YSF plugin: estos archivos estan governados por su licencia MPL 1.1.
  • Southclaws por su plantilla.
Imagen

No doy soporte por privado y no estoy disponible para ningún trabajo/proyecto/lo que sea. Eviten MPs de ese tema

Responder