Programación en Pawn - SAMP

Ayuda Foro SMF

Aporta, pregunta, ayuda sobre HTML, PHP, JavaScript, etc.
Hola comunidad de PawnScript, tengo un problema con el foro, quiero saber como puedo solucionar el error de la skin

Imagen

Gracias.
Sergitox escribió:
15 Sep 2018 11:42
Hola comunidad de PawnScript, tengo un problema con el foro, quiero saber como puedo solucionar el error de la skin

Imagen

Gracias.
¿Osea hay se tenia que ver la skin que llevas en el servidor? o un avatar cualquiera. ?
perdon se poco de foros SMF Fenixzone pero si se bastante de foros SMF XD
Daniel Walker escribió:
15 Sep 2018 12:19
Sergitox escribió:
15 Sep 2018 11:42
Hola comunidad de PawnScript, tengo un problema con el foro, quiero saber como puedo solucionar el error de la skin

Imagen

Gracias.
¿Osea hay se tenia que ver la skin que llevas en el servidor? o un avatar cualquiera. ?
perdon se poco de foros SMF Fenixzone pero si se bastante de foros SMF XD
La skin del la web debería ir en el SMF, este es el código pero no agarra ninguna skin
 Codigo Pawno:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

function template_body_above()
{
	global $context, $settings, $options, $scripturl, $txt, $modSettings;
	
	$usuario = $context['user']['name'];
	
	$query = mysql_query("SELECT FROM usuarios WHERE Username = '".$usuario."'");
	while ($row = mysql_fetch_assoc($query)) {
            $ropa       = $row['Skin'];
        }
	
	echo '
	<div id="bodybg">';
	echo !empty($settings['forum_width']) ? '
			<div id="wrapper">' : '', '
			  <div id="header">
				<div id="head-l">
					 <div id="head-r">
						  <div id="userarea" class="smalltext">';
			if ($context['user']['is_logged']){
			
			echo '
			<div id="my-avatar" class="clearfix">
				<img src="./imagenes/Skin/'.$ropa.'.png">
				
			</div>';
  Cantidad de llaves: Abiertas(3)-Cerradas(1) | Lineas Totales: 26
Sergitox escribió:
15 Sep 2018 12:24
Daniel Walker escribió:
15 Sep 2018 12:19
Sergitox escribió:
15 Sep 2018 11:42
Hola comunidad de PawnScript, tengo un problema con el foro, quiero saber como puedo solucionar el error de la skin

Imagen

Gracias.
¿Osea hay se tenia que ver la skin que llevas en el servidor? o un avatar cualquiera. ?
perdon se poco de foros SMF Fenixzone pero si se bastante de foros SMF XD
La skin del la web debería ir en el SMF, este es el código pero no agarra ninguna skin
 Codigo Pawno:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

function template_body_above()
{
	global $context, $settings, $options, $scripturl, $txt, $modSettings;
	
	$usuario = $context['user']['name'];
	
	$query = mysql_query("SELECT FROM usuarios WHERE Username = '".$usuario."'");
	while ($row = mysql_fetch_assoc($query)) {
            $ropa       = $row['Skin'];
        }
	
	echo '
	<div id="bodybg">';
	echo !empty($settings['forum_width']) ? '
			<div id="wrapper">' : '', '
			  <div id="header">
				<div id="head-l">
					 <div id="head-r">
						  <div id="userarea" class="smalltext">';
			if ($context['user']['is_logged']){
			
			echo '
			<div id="my-avatar" class="clearfix">
				<img src="./imagenes/Skin/'.$ropa.'.png">
				
			</div>';
  Cantidad de llaves: Abiertas(3)-Cerradas(1) | Lineas Totales: 26
Creo que es un error de CSS porque si fuera de direcorio te saldria un icono de una imagen que no existe con el nombre de la imagen, aca no... no aparece nada depronto es que el directorio del CSS no esta... haciendo imposible ver esta accion.
Daniel Walker escribió:
15 Sep 2018 17:38
Sergitox escribió:
15 Sep 2018 12:24
Daniel Walker escribió:
15 Sep 2018 12:19


¿Osea hay se tenia que ver la skin que llevas en el servidor? o un avatar cualquiera. ?
perdon se poco de foros SMF Fenixzone pero si se bastante de foros SMF XD
La skin del la web debería ir en el SMF, este es el código pero no agarra ninguna skin
 Codigo Pawno:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

function template_body_above()
{
	global $context, $settings, $options, $scripturl, $txt, $modSettings;
	
	$usuario = $context['user']['name'];
	
	$query = mysql_query("SELECT FROM usuarios WHERE Username = '".$usuario."'");
	while ($row = mysql_fetch_assoc($query)) {
            $ropa       = $row['Skin'];
        }
	
	echo '
	<div id="bodybg">';
	echo !empty($settings['forum_width']) ? '
			<div id="wrapper">' : '', '
			  <div id="header">
				<div id="head-l">
					 <div id="head-r">
						  <div id="userarea" class="smalltext">';
			if ($context['user']['is_logged']){
			
			echo '
			<div id="my-avatar" class="clearfix">
				<img src="./imagenes/Skin/'.$ropa.'.png">
				
			</div>';
  Cantidad de llaves: Abiertas(3)-Cerradas(1) | Lineas Totales: 26
Creo que es un error de CSS porque si fuera de direcorio te saldria un icono de una imagen que no existe con el nombre de la imagen, aca no... no aparece nada depronto es que el directorio del CSS no esta... haciendo imposible ver esta accion.
Puedes revisar desde la web: https://rol.royalzone.tk
Sergitox escribió:
15 Sep 2018 22:44
Daniel Walker escribió:
15 Sep 2018 17:38
Sergitox escribió:
15 Sep 2018 12:24


La skin del la web debería ir en el SMF, este es el código pero no agarra ninguna skin
 Codigo Pawno:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26

function template_body_above()
{
	global $context, $settings, $options, $scripturl, $txt, $modSettings;
	
	$usuario = $context['user']['name'];
	
	$query = mysql_query("SELECT FROM usuarios WHERE Username = '".$usuario."'");
	while ($row = mysql_fetch_assoc($query)) {
            $ropa       = $row['Skin'];
        }
	
	echo '
	<div id="bodybg">';
	echo !empty($settings['forum_width']) ? '
			<div id="wrapper">' : '', '
			  <div id="header">
				<div id="head-l">
					 <div id="head-r">
						  <div id="userarea" class="smalltext">';
			if ($context['user']['is_logged']){
			
			echo '
			<div id="my-avatar" class="clearfix">
				<img src="./imagenes/Skin/'.$ropa.'.png">
				
			</div>';
  Cantidad de llaves: Abiertas(3)-Cerradas(1) | Lineas Totales: 26
Creo que es un error de CSS porque si fuera de direcorio te saldria un icono de una imagen que no existe con el nombre de la imagen, aca no... no aparece nada depronto es que el directorio del CSS no esta... haciendo imposible ver esta accion.
Puedes revisar desde la web: https://rol.royalzone.tk
Ummm, esta raro eso.

Edit: Usaste la misma db que el de la gm?
Gabriel Ortiz escribió:
15 Sep 2018 22:55
Sergitox escribió:
15 Sep 2018 22:44
Daniel Walker escribió:
15 Sep 2018 17:38


Creo que es un error de CSS porque si fuera de direcorio te saldria un icono de una imagen que no existe con el nombre de la imagen, aca no... no aparece nada depronto es que el directorio del CSS no esta... haciendo imposible ver esta accion.
Puedes revisar desde la web: https://rol.royalzone.tk
Ummm, esta raro eso.

Edit: Usaste la misma db que el de la gm?
La web funciona bien, lo que falla es al obtener la id de la skin en el foro. // Apartado FORO.
Revivo, necesito ayuda

¿Quién está conectado?

En total hay 5 usuarios conectados :: 1 registrado, 0 ocultos y 4 invitados (basados en usuarios activos en los últimos 5 minutos)
La mayor cantidad de usuarios identificados fue 855 el 27 May 2018 00:03

Usuarios navegando por este Foro: Ramon y 4 invitados